Controles de entorno en SG Optimizer

Cómo usar HTTPS, PHP, GZIP y las opciones de caché del navegador para obtener el mejor resultado.

Controles HTTPS

¡Importante! Antes de habilitar HTTPS necesitas un certificado SSL emitido para el dominio de tu página. Por defecto, SiteGround emite de forma gratuita certificados de Let's Encrypt para todas las cuentas. Para comprobar si hay uno emitido en tu dominio WordPress, puedes usar la herramienta de Let's Encrypt en el cPanel.

Una vez emitido el SSL, puedes habilitar HTTPS a través del SG Optimizer. Esto configurará tu página para funcionar correctamente a través de HTTPS y forzará una conexión segura añadiendo una regla en tu archivo .htaccess. Hacer que tu página funcione mediante HTTPS también hará que vaya más rápido, ya que sólo las páginas HTTPS puede beneficiarse de la innovación y rapidez del protocolo HTTP2 que está disponible en nuestros servidores.

Una vez habilites HTTPS, verás otra opción – arreglar contenido inseguro. En la mayoría de los casos no es necesario activarlo. Úsalo sólo si notas avisos de contenido inseguro o mezclado en tu página web después de cambiar a HTTPS. Esta opción reescribirá dinámicamente los recursos cargados de modo inseguro para que funcionen mediante HTTPS. Aunque hemos desarrollado la reescritura para que sea bastante rápida, añadirá carga innecesaria al proceso de carga de tu sitio si ya está configurado para funcionar correctamente mediante HTTPS.

Controles de versiones PHP

Usualmente, las nuevas versiones PHP mejoran el rendimiento de los sitios web WordPress. Es por esto por lo que hemos añadido una opción de activación sencilla en nuestro plugin SG Optimizer.

Si todavía no usas la versión PHP que recomendamos, SG Optimizer te permitirá comprobar si tu sitio web es compatible. Si lo es, podrás cambiar a la versión recomendada con un clic. En caso de que recibas reportes sobre ciertos plugins/plantillas que no funcionan con la versión PHP recomendada, deberías ponerte en contacto con el desarrollador del plugin/plantilla para conseguir más información sobre cuándo estará listo su producto para esa versión PHP.

Aparte de la función de comprobar y cambiar la versión PHP recomendada, también te permitimos cambiar manualmente a cualquier versión PHP que sea compatible con nuestros servidores. Si necesitas usar esta opción, procede con cuidado ya que no tiene comprobador de compatibilidad y cambiar a una versión incompatible de PHP puede hacer que tu sitio inaccesible. Sin embargo, siempre puedes revertirlo usando el administrador de versión PHP en cPanel.

Compresión GZIP

Este es un mecanismo para comprimir tu contenido antes de transmitírselo a los navegadores de tus visitantes. Esto ahorra gran cantidad de conexiones y tráfico haciendo que tu página se cargue más rápido. Ten en cuenta que esta opción añade reglas a tu archivo .htaccess por lo que es necesario que elimines cualquier GZIP que exista relacionado con las reglas existentes si ya lo has añadido de forma manual.

Cacheado del navegador

Habilitando esta opción, nuestro plugin añadirá las reglas necesarias a tu archivo .htaccess para asegurar que el navegador de tus visitantes mantiene la caché estática tanto como sea posible haciendo que tu página se cargue extremadamente rápido para los visitantes que regresen.