Día cero del PHP 7 – Dale una oportunidad

PHP 7 disponible en los servidores de SiteGround

Ayer, PHP 7 alcanzó su estado de disponibilidad general. Como probablemente ya sepas, ha estado disponible en los servidores de SiteGround durante bastante tiempo como primicia para nuestros clientes. Ahora, ha alcanzado el estatus de GA lo que significa que PHP 7 se puede utilizar en sitios en producción.

Estado de PHP 7 en los CMS utilizados por nuestros clientes

Muchos de los CMS´s más populares en nuestros servidores y utilizados por nuestros clientes, como Drupal, WordPress y Joomla!, han decidido incorporar PHP 7. Algunos de ellos ya han anunciado oficialmente que su código es perfectamente compatible con PHP 7 y otros necesitarán más tiempo para llegar a ese punto. Esto es lo que indican nuestras pruebas a día de hoy:

  • Drupal 8: Oficialmente soporta PHP 7. Disponible para su descarga.
  • Drupal 7: Funciona con PHP 7. Disponible para descarga.
  • WordPress 4.3.1: Funciona con PHP 7. Disponible para descarga.
  • Joomla! 3.4.5: No soporta PHP 7.
  • Joomla! 3.5: Soporta PHP 7. Disponible en enero de 2016.

Por favor ten en cuenta que, incluso si estás utilizando una aplicación que soporta PHP 7.0, algunos de sus componentes como plugins, temas, módulos, etc. pueden tener código antiguo que no funcione en versiones más recientes. Es por ello que te recomendamos que siempre hagas una prueba en la zona de pruebas antes de habilitarlo en tu web.

¿Cómo habilitar PHP7 en los servidores de SiteGround?

Para habilitar PHP 7 para una determinada cuenta, o en parte de una cuenta, puedes utilizar el PHP Version Manager del cPanel:

PHP Version Manager in cPanel

Aviso importante para los usuarios de nuestro plugin SuperCacher para WordPress

Hasta ahora, nuestro plugin SuperCacher para WordPress (SG CachePress) ha estado utilizando el módulo Memcache PHP PECL. El Memcache PECL, sin embargo, no está disponible para PHP 7. PHP 7 sólo trabaja con Memcached. Por eso hoy hemos lanzado una nueva versión del plugin CachePress SG que utiliza Memcached , un nuevo PECL para PHP, que ofrece más funciones y un mejor rendimiento.

Si quieres beneficiarte del PHP 7 y de Memcached en tu web WordPress, por favor, sigue los siguientes pasos:

1. Actualiza el plugin SG CachePress a la última versión, la 2.3.0.
2. Deshabilita el plugin del panel de WP.
3. Vuelve a habilitar el plugin para aplicar la nueva configuración de Memcached.
4. Cambia la versión de PHP de tu web desde el cPanel -> Herramienta PHP Version Manager.

Ingeniero Senior en Web y Apps y Especialista en Rendimiento

Mi trabajo está muy relacionado con todo tipo de productos de software gratuito y de código abierto (algunos de mis favoritos son WordPress, Joomla !, Magento, Varnish y Apache mod_security). Como friki de la seguridad Web y del rendimiento siempre estoy híper concentrado en resolver todo tipo de problemas y en mejorar nuestros servicios.

Contestar

* (Requerido)